Epson R2880, ugly magenta prints

 
Post new topic   Reply to topic    ProPhotoForums.com Forum Index :: General Technical Discussions
View previous topic :: View next topic  
Author Message
Frank Ruiter
Forum Newbie


Joined: 30 Aug 2010
Posts: 1
Location: Amsterdam

PostPosted: Mon Aug 30, 2010 4:13 pm    Post subject: Epson R2880, ugly magenta prints Reply with quote

Hi Everybody,

I need to print my portfolio fast so i calibrated my monitor, used the correct profile for my paper (Moab Entrada from Lost Luggae) and still my prints turn out magenta. I checked if the ink was placed in the right way and it was. Is there anyone who can tell me what buttons to or not to push? It's driving me crazy. I'm not looking for books that take weeks to read since iI haven't got the time, just the correct couple of steps to take.
Im using CS3 and OS X 10.5.8

Thanx a lot!!!

Frank Ruiter
Back to top
View user's profile Send private message Send e-mail Visit poster's website
Mike
Forum Regular


Joined: 22 Mar 2006
Posts: 231
Location: Los Angeles, where fun goes on vacation

PostPosted: Mon Aug 30, 2010 4:29 pm    Post subject: Reply with quote

Frank-

The usual quick answer to magenta prints is double profiling, where you are telling both photoshop and your printer to apply the printing profile. Be sure are only having PS do the profile by disabling any printer adjustments.
Back to top
View user's profile Send private message
Brooks Ayola
Supreme Overlord


Joined: 08 Mar 2006
Posts: 542
Location: Chatsworth (Los Angeles), CA

PostPosted: Fri Sep 03, 2010 12:49 am    Post subject: Reply with quote

Did you ever get this sorted out, Frank?
_________________
Brooks Ayola
Ayola.com
Brooks Blog
Back to top
View user's profile Send private message Send e-mail Visit poster's website AIM Address
James Cook
Forum Regular


Joined: 21 Nov 2008
Posts: 85
Location: Saugatuck

PostPosted: Fri Sep 03, 2010 11:40 am    Post subject: Reply with quote

I've experienced it with another Epson (7880) and it was clogged jets.
_________________
James Cook

Creator of:
METAmachine
FindAPhotographer
Back to top
View user's profile Send private message Visit poster's website
rod
Forum Regular


Joined: 02 Sep 2008
Posts: 68
Location: New York, NY

PostPosted: Fri Sep 03, 2010 11:55 am    Post subject: Reply with quote

I just had this happen yesterday with my R1900,

I was printing, all looked great, I ran out of yellow, put in a new yellow, it showed full. I printed and, magenta prints.

I called Epson, I ran the check nozzle utility and it showed no yellow at all. I ran the nozzle cleaning twice and the yellow kicked in.
Back to top
View user's profile Send private message Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    ProPhotoForums.com Forum Index :: General Technical Discussions All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum




Powered by phpBB © 2001, 2002 phpBB Group
Charcoal2 Theme © Zarron Media